Issue: Mockaroo API POST generate(.format) - SQL and XML

When using a POST request to the generate ENDPOINT for either SQL or XML format, result in an error:

XML- {“error”:“undefined method `xml_root_element’ for nil:NilClass”}

SQL - {“error”:“undefined method `table_name’ for nil:NilClass”}

I tried passing a table_name query parameter for the SQL format like:“ schema=Person&table_name=personkey=my_api_key”)

As see other users are having similar issues:

Has anyone else encountered these errors and found a solution? I’ve tried various combinations of query parameters without success. Any help or insights from Mockaroo support would also be appreciated.

Thanks in advance.

This should be fixed now.

Thank you!

The “XML” format seems to be working correctly, but I’m still receiving an error message for the “SQL” format. The error message states “undefined method `table_name’ for nil:NilClass”.

Here is my URL request:{my_key}

SQL should now be fixed as well.

Thanks, it is working now!